Cisco - Protocoles de routage

Sommaire

  1. Introduction
  2. Protocole RIP
  3. Protocole OSPF
  4. Protocole EIGRP
  5. Protocole BGP

Introduction

Tout d'abord, pourquoi présenter ces protocoles de routage ?

Car ils sont utilisés dans la plupart des entreprises du monde et surtout ces protocoles de routage font parti du programme CCNA de Cisco.

Protocole RIP

  • RIP : Routing Internet Protocol
  • Type : vecteur de distance
  • Il existe deux versions :
RIP version 1 (RFC 1058)

Ce qu'il faut en retenir :

  • ne gère pas les masques sous-réseau de longueur variable (VLSM)
  • ne gère pas l'authentification entre routeur
RIP version 2 (RFC 2453)

Ce qu'il faut en retenir :

  • gère pas les masques sous-réseau de longueur variable (VLSM)
  • gère pas l'authentification entre routeur
  • les routes transitent sur l'adresse multicast 224.0.0.9

Sur Cisco, ça donne quoi ?

 
    routeur1#configure terminal
    routeur1(config#router rip
    routeur1(config-router)#version 2
    routeur1(config-router)#network 10.0.10.0

Nous activons la version 2 qui n'est pas active par défaut.

Ensuite il faut définir les réseaux que l'on veut diffuser.

Protocole OSPF

  • OSPF : Open Shortest Path First
  • Type : à état de liens
  • But : remplacer RIP
  • Version 2 (RFC 1247)

Ce qu'il faut en retenir :

  • les routeurs créent des relations "d'adjacence" avec ses voisins directs grâce à des messages Hello à intervalle régulier
  • les routeurs diffusent leurs listes de réseaux par le biais de message LSA (Link-state advertisements)
  • la route la plus courte est déterminée grâce à l'algorithme de Dijkstra
  • les portions de réseaux sont segmentaires en aire

Informations sur les aires :

  • les aires servent à ne pas propager l'ensemble des liens d'un réseau connecté à un routeur afin de ne pas surcharger la mise à jour des liens, chaque aire est numérotée
  • il existe au moins une aire, l'aire dorsale (backbone area) est toujours nommée 0
  • la numéroration des aires est contiguës
  • les échanges de données se font en multicast, sur l'adresse 224.0.0.5

Transmission des routes (élection d'un DR et d'un BDR) :

  • la diffusion de l'état des liens entre chaque routeur adjacent serait excessive si chaque routeur diffuse leurs liens avec leurs routeurs adjacents
  • la solution est d'élire un DR (Designated Router, ou routeur désigné) qui recevra toutes les informations sur l'état des liens et les rediffuser aux autres routeurs
  • pour palier au problème de la perte du DR, un BDR (Backup Designated Router, ou routeur désigné de secours)
  • le Designated Router est élu grâce au router-id (adresse ip la plus haute)

Sur Cisco, ça donne quoi ?

  routeur1#configure terminal
    routeur1(config)#router ospf 1
    routeur1(config-router)#network 10.0.1.0 0.0.0.255 area 0

Il faut en mode "conf t", entrer la commande router ospf "process-id", où process-id est entre 1 et 65535, ce numéro sert à routeur à identifier une configuration ospf d'une autre sur lui-même, il n'a aucun rapport avec les aires.

Ensuite il faut ajouter les réseaux que l'on veut diffuser, ici le réseau 10.0.1.0, avec son masque de sous-réseau inversé (wildcard) et sur quel aire il appartient.

Pour forcer l'élection d'un DR et d'un BDR, nous mettons une adresse de loopback comme ceci :

 
    routeur1#configure terminal
    routeur1(config)#int loopback 0
    routeur1(config-interface)#ip address 192.192.192.3 255.255.255.0
    routeur1(config-interface)#no shutdown

Il faut notamment l'adresse de loopback pour faire des liens virtuels en aire non adjacente.

Pour créer des liens virtuels entre des aires non adjacente (qu'une zone 0 et 2 puissent communiquer par l'intermédiaire d'une zone 1) :

 
    routeur1#configure terminal
    routeur1(config)#router ospf 1
    routeur1(config-router)#area 0 virtual-link @loopback-A
    routeur1(config-router)#area 2 virtual-link @loopback-B

Pour l'élection DR/BDR, si nous ne voulons pas qu’un routeur participe au processus d’élection, il faut mettre sur l'interface voulue "ip ospf priority 0".

Authentification entre routeurs :

Il faut activer l'authentification sur la configuration OSPF :

 
    routeur1#configure terminal
    routeur1(config)#router ospf 1
    routeur1(config-router)#area 0 authentication

Sur l'interface d'interconnexion avec les autres réseaux :

 
    routeur1#configure terminal
    routeur1(config)#interface FastEthernet0/0
    routeur1(config-interface)#ip address 10.0.1.1 255.255.255.252
    routeur1(config-interface)#ip ospf authentication ; active l’authentification
    routeur1(config-interface)#ip ospf authentication-key cisco ; donne la clé qu’il faut utiliser pour pouvoir s’authentifier.

Protocole EIGRP

  • EIGRP : Enhanced Interior Gateway Routing Protocol
  • Développé par Cisco
  • Basé sur IGRP, par rapport à ce dernier, il est classless (il est capable de gérer VLSM).
  • Utilisaton de l'algorithe DUAL afin d'avoir une convergence de route plus rapide.
  • Distance administrative : 90 (en interne).

Son fonctionnement en quelques étapes :

  • Il découvre les voisins via des message Hello.
  • Les routeurs échangent leurs topologie, à chaque fois qu'un nouveau voisin est découvert (via des Update).
  • Choix des meilleures routes en fonction de 4 paramètres (Bande passante, Charge, Délai et Fiabilité) .

Sur Cisco, ça donne quoi ?

  routeur1#configure terminal
    routeur1(config)#router eigrp 1000
    routeur1(config-router)#redistribute eigrp 2000
    routeur1(config-router)#network 10.0.1.0 0.0.0.255
    routeur1(config-router)#no auto-summary

1000 et 2000 sont des systèmes autonomes (AS).

Protocole BGP

  • BGP : Border Gateway Protocol
  • Protocole à vecteur de chemins
  • Echange basé sur les systèmes autonomes (AS)
  • Gère VSLM et l'agrégation de routes
  • La version 4 est utilisé sur Internet actuellement (RFC 4271).

Son fonctionnement en quelques étapes :

  • Il faut configurer les connexions entre voisins explicitement.
  • Les routeurs communiquent sur le port 179 en TCP.
  • Une fois la connexion entre voisins établit, ceux-ci échangent les réseaux qu'ils connaissent.

Sur Cisco, ça donne quoi ?

Partons du principe que routeur1 gère le système autonome 20.

  routeur1#configure terminal
    routeur1(config)#router bgp 20
    routeur1(config-router)#network 10.0.1.0 mask 255.255.255.0
    routeur1(config-router)#network 10.0.2.0 mask 255.255.255.0
    routeur1(config-router)#neighbor 10.0.1.1 remote-as 10
    routeur1(config-router)#neighbor 10.0.2.2 remote-as 30

Nous déclarons les réseaux 10.0.1.0 et 10.0.2.0 qui lui sont directement connectés et nous déclarons les systèmes autonomes voisins, ce que celui-ci ne fait pas automatiquement.